Back to overview
Degraded
Performance degradation
May 6, 2026 at 1:29pm UTC
Affected services
S-Docs for HubSpot
Document generation
Data & Integration
E-Signature
Resolved
May 6, 2026 at 3:10pm UTC
The errors rates have gone down to 0. We will continue to monitor the overall performance.
Affected services
Created
May 6, 2026 at 1:29pm UTC
We are actively monitoring a high level of errors in our esignature and document generation services. We have restarted the services and will be monitoring this and post updates if there more corrective actions needed.
Affected services