Back to overview
Resolved

Signer links not working

Jun 25, 2026 at 4:35pm UTC
Affected services
E-Signature

Resolved
Jun 29, 2026 at 5:45am UTC

S-Docs has deployed emergency patch release to resolve the signer link issue. Refer to https://status.sdocs.com/maintenance/930764 for the maintenance timeline.

Updated
Jun 25, 2026 at 5:00pm UTC

We have identified the root cause and are working on a fix to deploy to production.

As a workaround we ask customers to either requeue the request via hubspot workflow or click the "Resend" button in the audit trail for the request in S-Docs.

Created
Jun 25, 2026 at 4:35pm UTC

On Tuesday evening, June 23rd, we released an update to the HubSpot application that included a set of security improvements. Unfortunately, one of those security changes introduced a bug that is causing errors for signers when they attempt to access signing links.

We sincerely apologize for any disruption this has caused to your workflows.

Here's where things stand:

• We have identified the root cause of the issue.
• Our team is actively working on a fix.
• We will push the corrected build to production as soon as it's ready and validated.
• Email support@sdocs.com in case you need help while we are working on the fix.