Back to overview
Resolved

Performance degradation

Jul 22, 2026 at 5:45pm UTC
Affected services
S-Docs for HubSpot
Identity and authentication
Document generation
Data & Integration
E-Signature

Resolved
Jul 22, 2026 at 6:44pm UTC

all services are operating normally. The server restarts resolved the issue.

Created
Jul 22, 2026 at 5:45pm UTC

S-Docs team noticed a database connectivity issue that impacted all services. We have proactively restarted the services. Workflow and e-signature requests were impacted as a result of this restart. S-Docs is actively monitoring the servers after restart.